Commit 4cc0f42d authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Fixed pyproj DeprecationWarning. Added 'packaging' as pip requirement. Updated...


Fixed pyproj DeprecationWarning. Added 'packaging' as pip requirement. Updated HISTORY.rst. Bumped version.
Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 088291d8
Pipeline #19430 failed with stages
in 13 minutes and 17 seconds
......@@ -20,6 +20,7 @@ test_py_tools_ds:
stage: test
script:
- source /root/miniconda3/bin/activate ci_env
- pip install packaging # TODO remove when CI runner is rebuilt
- make nosetests
- make docs
artifacts:
......
......@@ -2,6 +2,15 @@
History
=======
0.16.8 (2021-02-16)
-------------------
* Updated GitLab URLs due to changes on the server side.
* Fixed remaining .coverage file after running 'make clean'.
* Replaced deprecated numpy data types as they are only aliases of the builtin data types.
* Fixed pyproj DeprecationWarning. Added 'packaging' as pip requirement.
0.16.7 (2020-12-15)
-------------------
......
......@@ -82,7 +82,8 @@ def prj_equal(prj1, prj2):
return True
else:
from pyproj import __version__ as ver
if ver.startswith('2') and int(ver.split('.')[1]) >= 5:
from packaging.version import parse
if parse(ver) >= parse('2.5'):
# CRS.equals was added in pyproj 2.5 which does not exist for Python 2.7 in conda-forge channel
crs1 = CRS.from_user_input(prj1)
crs2 = CRS.from_user_input(prj2)
......
......@@ -40,6 +40,7 @@ requirements = [
'gdal>=2.1.0',
'geopandas',
'numpy',
'packaging', # remove when dropping Python 2.7 support
'pandas',
'pyproj>=2.2.0',
'scikit-image',
......
......@@ -14,6 +14,7 @@ dependencies:
- shapely
- pip:
- packaging
- six
- spectral
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment