Commit 6ba13a29 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Removed deprecated 'maxfeatCount' keyword. Updated minimal version of...


Removed deprecated 'maxfeatCount' keyword. Updated minimal version of py_tools_ds to 0.19.0 (revises raster2polygon and fill_holes_within_poly). Bumped version.
Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 728ab0a0
Pipeline #30322 passed with stages
in 2 minutes and 34 seconds
......@@ -2,6 +2,12 @@
History
=======
0.15.3 (11.11.2021)
-------------------
* Removed deprecated 'maxfeatCount' keyword.
* Updated minimal version of py_tools_ds to 0.19.0 (revises raster2polygon and fill_holes_within_poly).
0.15.2 (29.10.2021)
-------------------
......
......@@ -495,7 +495,7 @@ class GeoArray(object):
else:
try:
multipolygon = raster2polygon(self.mask_nodata.astype(np.uint8), self.gt, self.prj, exact=False,
progress=self.progress, q=self.q, maxfeatCount=10, timeout=15)
progress=self.progress, q=self.q, timeout=15)
self._footprint_poly = fill_holes_within_poly(multipolygon)
except (RuntimeError, TimeoutError):
if not self.q:
......
......@@ -22,5 +22,5 @@
# limitations under the License.
__version__ = '0.15.2'
__versionalias__ = '20211029.01'
__version__ = '0.15.3'
__versionalias__ = '20211111.01'
......@@ -45,7 +45,7 @@ req = [
'numpy',
'pandas',
'pyepsg', # optional dependency of cartopy, needed by geoarray
'py_tools_ds>=0.18.0',
'py_tools_ds>=0.19.0',
'scikit-image',
'shapely'
]
......
......@@ -11,7 +11,7 @@ dependencies:
- holoviews
- matplotlib
- numpy
- py-tools-ds>=0.18.0
- py-tools-ds>=0.19.0
- scikit-image
- shapely
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment