Commit 1efbcdf4 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Added pyepsg to requirements as it is now an optional requirement of cartopy...


Added pyepsg to requirements as it is now an optional requirement of cartopy but still used in geoarray. Updated version info.

Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent bc836e36
Pipeline #15036 passed with stages
in 50 seconds
......@@ -2,6 +2,12 @@
History
=======
0.10.2 (2020-10-27)
-------------------
* Removed cartopy pinning and added a warning about the missing grid labels in GeoArray.show() with cartopy<0.18.0.
0.10.2 (2020-10-27)
-------------------
......
......@@ -1323,9 +1323,17 @@ class GeoArray(object):
origin='upper', transform=crs_in, extent=list(self.box.boundsMap))
# show grid lines
# NOTE: The current version of cartopy can only label PlateCarree grid lines - (crs=crs_out) is not yet
# supported and the labels are just missing in that case.
ax.gridlines(draw_labels=True, linewidth=2, color='gray', alpha=0.5, linestyle='--')
try:
# cartopy>=0.18.0 only
# NOTE: The current version of cartopy (0.18.0) can only label PlateCarree grid lines -
# (crs=crs_out) is not yet supported and the labels are just missing in that case.
ax.gridlines(draw_labels=True, linewidth=2, color='gray', alpha=0.5, linestyle='--')
except TypeError as e:
if 'Cannot label gridlines on a _EPSGProjection plot.' in str(e):
warnings.warn('The grid line labels cannot be drawn with cartopy<0.18.0.')
ax.gridlines(draw_labels=False, linewidth=2, color='gray', alpha=0.5, linestyle='--')
else:
raise
if return_map:
return fig, ax
......
......@@ -20,5 +20,5 @@
# with this program. If not, see <http://www.gnu.org/licenses/>.
__version__ = '0.10.2'
__versionalias__ = '20201027.02'
__version__ = '0.10.3'
__versionalias__ = '20201028.01'
......@@ -36,7 +36,7 @@ with open("geoarray/version.py") as version_file:
exec(version_file.read(), version)
requirements = [
'cartopy>=0.18.0',
'cartopy',
'dill',
'folium',
'gdal>=2.1.0',
......
......@@ -6,7 +6,7 @@ channels: &id1
dependencies:
- python=3.*.*
- pip # avoids that conda uses the wrong pip
- cartopy>=0.18.0
- cartopy
- gdal>=2.1.0
- holoviews
- matplotlib
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment