Commit 710a6870 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Dropped support for Python versions below 3.6.


Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 0e272c93
Pipeline #20514 passed with stage
in 3 minutes and 51 seconds
......@@ -120,7 +120,7 @@ Before you submit a pull request, check that it meets these guidelines:
2. If the pull request adds functionality, the docs should be updated. Put
your new functionality into a function with a docstring, and add the
feature to the list in README.rst.
3. The pull request should work for Python 2.6, 2.7, 3.3, 3.4 and 3.5, and for PyPy. Check
3. The pull request should work for Python 3.6+, and for PyPy. Check
https://travis-ci.org/danschef/arosics/pull_requests
and make sure that the tests pass for all supported Python versions.
......
......@@ -24,7 +24,6 @@
import warnings
import os
from copy import copy
from six import PY2
from typing import TYPE_CHECKING
# custom
......@@ -176,9 +175,6 @@ class COREG_LOCAL(object):
warnings.warn("'-out_gsd' is ignored because '-match_gsd' is set.\n")
if out_gsd:
assert isinstance(out_gsd, list) and len(out_gsd) == 2, 'out_gsd must be a list with two values.'
if PY2 and (CPUs is None or (isinstance(CPUs, int) and CPUs > 1)):
CPUs = 1
warnings.warn('Multiprocessing is currently not supported for Python 2. Using singleprocessing.')
self.params = dict([x for x in locals().items() if x[0] != "self" and not x[0].startswith('__')])
......
......@@ -59,8 +59,8 @@ you through the process.
.. note::
AROSICS has been tested with Python 3.4+ and Python 2.7. It should be fully compatible to all Python versions
from 2.7 onwards. However, we will continously drop the support for Python 2.7 in future.
AROSICS has been tested with Python 3.6+. It should be fully compatible to all Python versions
from 3.6 onwards. Python 2.7 support was dropped in AROSICS 1.3 due to its end of life status.
.. _pip: https://pip.pypa.io
......
......@@ -15,4 +15,3 @@ pyproj>2.2.0
py_tools_ds>=0.15.10
scikit-image>=0.16.0
shapely
six
folium>=0.6.0,!=0.12.0
geojson
plotly
six
......@@ -55,7 +55,6 @@ req = [
'py_tools_ds>=0.15.10',
'scikit-image>=0.16.0',
'shapely',
'six',
]
req_setup = [
......@@ -83,8 +82,6 @@ setup(
'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
'Natural Language :: English',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
......
......@@ -27,7 +27,6 @@ dependencies:
- folium>=0.6.0,!=0.12.0
- geojson
- plotly
- six
# doc requirements
- coverage
......
[tox]
envlist = py26, py27, py33, py34, py35, flake8
envlist = py36, py37, py38, py39, flake8
[travis]
python =
3.5: py35
3.4: py34
3.3: py33
2.7: py27
2.6: py26
3.9: py39
3.8: py38
3.7: py37
3.6: py36
[testenv:flake8]
basepython=python
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment