Unverified Commit d5326b46 authored by Raniere Silva's avatar Raniere Silva Committed by GitHub
Browse files

Merge pull request #555 from mkcor/patch-3

Update check from IPython package to Jupyter.
parents 6864fe3d 0f900529
......@@ -835,14 +835,16 @@ for package,name,long_name,minimum_version,and_dependencies in [
CHECKER['py.test'].minimum_version, None),
('jinja2', 'jinja', 'Jinja', (2, 6), None),
('zmq', 'pyzmq', 'PyZMQ', (2, 1, 4), None),
('IPython', None, 'IPython Python package',
CHECKER['ipython'].minimum_version, [
('jupyter', None, 'Jupyter',
# FIXME should use minimum version for Jupyter
# CHECKER['ipython'].minimum_version, [
None, [
'jinja',
'tornado',
'pyzmq',
VirtualDependency(
name='virtual-browser-ipython',
long_name='IPython-compatible web browser',
long_name='Jupyter-compatible web browser',
or_dependencies=[
CommandDependency(
command=CHECKER['firefox'].command,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment