setup.py 446 Bytes
Newer Older
1
2
3
4
#!/usr/bin/python3

from setuptools import setup, find_packages

Marius Kriegerowski's avatar
Marius Kriegerowski committed
5
test_requirements = ["pylint", "flake8", "black", "pytest"]
6
7
8
9
10
11
12

setup(
    name="shakyground2",
    version="0.1.0",
    description="",
    license="AGPLv3+",
    extras_require={"tests": test_requirements},
13
14
15
    install_requires=[
        "openquake.engine",
        "geopandas",
Peter Evans's avatar
Peter Evans committed
16
        "pyyaml",
17
        "Rtree",
18
    ],
19
20
21
    packages=find_packages(),
    python_requires=">=3.7",
)