Commit 6e31fc27 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

updated GDAL version check, __version__

ptds.__init__: updated GDAL version check
parent bea75bf5
......@@ -16,21 +16,21 @@ __all__=['io',
'processing',
'GeoArray']
__version__ = '20161027_01'
__version__ = '20161029_01'
__author__='Daniel Scheffler'
# Validate GDAL version
try:
import gdal
import gdalnumeric
except:
except ImportError:
from osgeo import gdal
from osgeo import gdalnumeric
try:
gdal.Warp
gdal.Translate
gdalnumeric.OpenNumPyArray
getattr(gdal,'Warp')
getattr(gdal,'Translate')
getattr(gdalnumeric,'OpenNumPyArray')
except AttributeError:
import warnings
warnings.warn("Your GDAL version is too old to support all functionalities of the 'py_tools_ds' package. "
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment